quake 3 in Ubuntu…

Home Forums General Banter quake 3 in Ubuntu…

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #66216

    So; turns out the guys at Ubuntu didn’t think anyone would still be using OSS anymore and have removed the snd_pcm_oss modules from the kernel. As such, no more audio if you wanna play Quake 3. hashtag bastards

    Venn Stone

    Have you tried running it /w padsp?


    Wow what is this? 2012?
    The OSS module has been removed from the Debian kernel *years* ago, and yes there are solutions to get sound working with legacy OSS games.

    padsp is old as fuck, it works sometimes but is a PITA to deal with when running 32bit games on 64bit systems.
    aoss is even older and works even less
    The way to go is osspd (http://sourceforge.net/projects/osspd/) which is just a package to install and you get sound in *all* OSS games, even fucked up ones such as Enemy Territory.

    Now, there is one problem with osspd. The Debian devs have been fucking around with kernel options and have reintroduced one that breaks osspd. If you are running Ubuntu 14.10 (which I am), you get no sound unless you recompile the kernel without that option.

    This is reported here https://bugs.launchpad.net/ubuntu/+sour … ug/1366794 and hope this will get fixed before the release

    PS: Stop blaming Ubuntu for what Debian does
    PS2: I hope that when you say Quake3 you actually refer to ioquake3


    PS – sarcasm
    PS2 – yes ioquake3

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.