Sources Games, AMD Cards and FPS Hitching

Home Forums Steam On Linux Sources Games, AMD Cards and FPS Hitching

Viewing 1 post (of 1 total)
  • Author
  • #65339
    Pedro Mateus

    As it turns out, VSync doesn’t do squat when it comes to synchronizing the frames in source games.

    But there is a variable you can set manually to limit the frames to a specific value. fps_max XX

    On my calculator, I was getting around 100-ish FPS on L4D2 which would spike to 120 every now and again and cause the visual hitching.

    The 13.15 Beta drivers from AMD help reduce this some, but in order to get rid of it almost completely I still had to set fps_max to 85.

    There are several ways to do this:

    – Add fps_max 85 to your game’s autoexec.cfg (eg:$HOME/.local/share/Steam/SteamApps/common/Left 4 Dead 2/left4dead2/cfg/autoexec.cfg)

    – Manually set it on the game’s console by typing fps_max 85

    – Or add +fps_max 85 as a launch option.

    If at 85 FPS you’re still experiencing the frequent hitching, try lowering the value until it goes away.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.