What are your Steam specs?

Home Forums Steam On Linux What are your Steam specs?

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
  • #65259
    Venn Stone

    Just wondering what everyone is running. And, have you had any show stoppers along the way?


    CPU: AMD 640 X4

    RAM: 5GB

    GPU: Nvidia 560Ti

    Driver: 310

    OS: Ubuntu 12.04 32-bit


    SS3BFE is the only game that has a MASSIVE bug with my setup. It fails to capture the mouse. This disables my ability to rotate the full 360. The critters at Croteam have promised a fix Monday’ish.


    Here are my specs for my linux Steam box.


    CPU: Intel i5-3570

    RAM: 16GB

    GPU: Nvidia 560

    Driver: 310

    OS: Arch 3.6.6 PAE kernel 32-bit :p

    COLOUR: Dark


    Deciphering the coin toss.

    Pedro Mateus

    I’m always up for whoring my laptop’s specs getting a free game out of it is just the icing on my whoring self! Don’t read too much into that, I didn’t.

    My laptop used to be a Toshiba Satellite L650-1HM, its current specs are the following:

    CPU: Intel Core i3 370M (2.40GHz)

    RAM: 8GB DDR3 1033MHz

    Display: AUO Full HD 15.6″ (1920×1080) upgraded from stock (1366×768)

    GPU: ATI Radeon Mobility HD 5650 (GP Overclocked to factory max of 650MHz, from the stock 450MHz)

    Driver: FGLRX 12.11 Beta

    Storage: Dual OCZ Agility 3 (120 & 60GB) (removed optical drive)

    OS: Fuduntu 2012.4 x86_64 (Yeah I’m one of those guys ^.^)

    I’ve been itching to buy a processor to upgrade the i3, but I don’t get payed that well. >.>

    Problems: Fuduntu still doesn’t have all the dependencies for the Fedora version of Steam to run out of the box… yet!

    Oh and Venn’s favorite color is Dark and Jordan doesn’t have one!

    Here are my desktop specs, not that impressive.

    Kernel: Linux 3.2.0-33-generic i686

    Distro: Ubuntu 12.04.1 LTS

    CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4800+

    2 cores/threads

    2511.444 MHz

    RAM: 1.96 GiB

    GPU: GeForce 8400 GS/PCIe/SSE2/3DNOW!

    OpenGL 3.3.0 NVIDIA 310.14

    GLSL 3.30 NVIDIA via Cg compiler

    Problems: TF2 is a bit laggy and causes my Core0 temperature to go up to 80c!

    Serious Sam 3 runs horribly.

    Killing Floor works fine though.

    Distro: Ubuntu 12.10

    CPU: Inter Dual-Core 2.3 GHZ

    RAM: 2GB

    GPU: Geforce 210

    Driver: Nvidia R310.14

    Problems: When launching TF2 I can see background for like 20 seconds and then game crashes.

    @burningfool doesn’t have favorite color.

    favorite color is either dark or dog(You said it twice yet I still coudn’t understand)


    CPU: AMD Athlon X2 250 (3GHz)

    RAM: 4GB DDR3

    GPU: Nvidia GT220

    Driver: 310

    OS: Linux Mint 13 64-bit

    Problem: TF2 crashes after the source logo, tried to fix it whit adding export LANG=C

    to the /usr/bin/steam file whit gedit but it didn’t help.

    Venn called sideways, his favorite color is: Dark, Jordan’s favorite color was: I don’t have one :D

    Distro: Ubuntu 12.10 64-bit

    CPU: i7-2600K 3.40GHz

    RAM: 16 GB DDR3

    GPU: GeForce GTX 570

    Problem – Serious Sam 3 is just pure black when I played it. Menu worked and game plays but all graphics are black

    Venn’s favorite color is dark (not a color)

    Jordan’s favorite color is “I don’t have one” (also not a color)
    Steam System:

    CPU: Intel Core 2 Duo @ 2.2 GHz

    RAM: 4GB

    GPU: Intel G41

    Drivers: 2.20.13

    OS: Arch Linux x86_64


    After installing TF2, Steam doesn’t run, it says:

    “Installing breakpad exception handler for appid(steam)/version(1353371323_client)

    SteamUpdateUI: An X Error occurred

    X Error of failed request: BadMatch (invalid parameter attributes)

    Major opcode of failed request: 154

    (which is )

    Minor opcode of failed request: 26

    Serial number of failed request: 22

    xerror_handler: X failed, continuing”

    New problem: TF2 runs, but the whole screen is black

    Venn’s favourite colour is dark and Jordan’s does not exist.

    First let me say that, Venn, at first it sounded like your favorite color was “dog” but that’s not a color. Since you’re locked in a dark cell all the time I figured you must have said “dark”. So, I watch again and, yeah, I’m pretty sure you said “duck” but it could have also been “dog”. Your favorite color is probably “dog”. Which is a weird coincidence because Jordan said he doesn’t have a favorite color. Probably because he IS a dog and only sees in shades of grey (50 shades of grey?) .

    System info. at the bottom as provided by Steam, slightly modified to remove blank or really uninteresting information. In addition to the following I’d like to add that I use AwesomeWM, my Steam directory is symlinked, and I can’t figure out how to add non-Steam games.

    ? ~ ls -al /home/johnny/Steam

    lrwxrwxrwx 1 johnny johnny 17 Nov 8 16:02 /home/johnny/Steam -> /data/Games/Steam

    Issues I’ve faced:

    There haven’t been any show-stoppers but a few issues have come up that I resolved by upgrading Ubuntu to 12.1 and the Nvidia driver to 310.14.

    Serious Sam 3: BFE had some serious errors any time I looked at a light source: frame rate would drop horribly and the shaders (I think, I’m not so good with graphics terminology) would act all messed up and display some interesting shapes. It was unplayable until I upgraded.

    Team Fortress 2 stuttered frequently and was generally slow to load. Played with nvidia-settings to get the game FPS at a good level. I’m unsure of how to enable an FPS display but I’ll work on that. I noticed that changing graphics settings in game seems to freeze the software for a bit. After a while of waiting it comes back to life. I’m working on getting some benchmarks to contribute to a reddit post that shows Windows vs. Linux performance.

    Killing Floor hasn’t had problems yet but it has been slow. Haven’t played again with modified nvidia-settings.

    System specs:

    Processor Information:

    Vendor: GenuineIntel

    Speed: 2933 Mhz

    2 logical processors

    2 physical processors

    HyperThreading: Unsupported

    FCMOV: Supported

    SSE2: Supported

    SSE3: Supported

    SSSE3: Supported

    SSE4a: Unsupported

    SSE41: Unsupported

    SSE42: Unsupported

    Operating System Version:

    Ubuntu 12.10 (32 bit)

    Kernel Name: Linux

    Kernel Version: 3.5.0-18-generic

    X Server vendor: The X.Org Foundation

    X Server release: 11300000

    Video Card:

    Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2

    Driver Version: 4.3.0 NVIDIA 310.14

    Desktop Color Depth: 24 bits per pixel

    Monitor Refresh Rate: 60 Hz

    VendorID: 0x10de

    DeviceID: 0xe22

    Number of Monitors: 2

    Number of Logical Video Cards: 1

    Primary Display Resolution: 1280 x 1024

    Desktop Resolution: 2560 x 1024

    Primary Bus: PCI Express 16x

    Primary VRAM: 1023 MB

    Supported MSAA Modes: 2x 4x 8x 16x

    Sound card:

    Audio device: ICE1712 – multitrack


    RAM: 6064 Mb


    UI Language: English

    LANG: en_US.UTF-8

    Microphone: Not set

    Total Hard Disk Space Available: 704175 Mb

    Largest Free Hard Disk Block: 561675 Mb

    CPU: i5 750
    RAM: 4GB
    GPU: Nvidia GTX 285
    OS: Gentoo
    Kernel: 3.4.9
    Drivers: 310.19

    It all runs surprisingly well for me, past the initial effort to get it installed on Gentoo. TF2 runs at ~65FPS, which is only about 15-20FPS less than I get in Windows (but not really noticable to me), and was very stable while playing it for many hours. Serious Sam 3 is probably the best looking native Linux game I’ve seen and runs very well too, I’ve not had any issues yet besides the odd stutter.

    I’ve not tested them specifically, but I get the feeling that the updated Nvidia drivers make a big difference, as I keep seeing people with better specs than me getting worse performance on older drivers.

    I’ve had some issues with sound, the Steam overlay, and the client updating at some point, but I think these are mostly down to using an unsupported distro and not having all the dependencies/settings that they expect. The only problem left is that it keeps changing my mouse pointer, which is quite annoying. Multi monitor support also isn’t great, but that’s always been the case with any sort of games on Linux for me.


    Kernel: 3.6.3-1.fc17.x86_64
    Distro: Fedora 17 64-bit
    Sys Board: Intel X38
    CPU: C2D E8400 @ 3Ghz
    Memory: 8GB DDR2
    Graphics: NVIDIA 8800 GTS 640 MB


    CPU: Intel Core i7 2.2GHz
    RAM: 8GB
    GPU: Intel HD Graphics 3000 / AMD Radeon HD 6750M
    Driver: nouveau or nvidia
    OS: Xubuntu 12.10


    Distro: Ubuntu 12.10 64-bit
    CPU: AMD Phenom(tm) II N970 Quad-Core Processor x
    RAM: 8 GB
    GPU: [Mobility Radeon HD 4200 Series]

    Problem – Team Fortress 2 runs at 9 fps. I’ve had 15 in Windows.

    Venn’s favorite color is dark (not a color)*
    Jordan’s favorite color is “I don’t have one” (also not a color)*
    according to my sources.


    Distro: Linux Mint14 MATE 64-bit
    CPU: Intel Core 2 Duo P8700 @ 2.53GHz
    RAM: 4GB
    GPU: Mobility Radeon HD 4570
    Driver: fglrx-legacy(Catalyst 12.6 legacy)

    Issue: Team Fortress 2 refuses to run due to missing OpenGL feature in fglrx-legacy driver. No newer driver is available from AMD for this GPU.

    Your favourite colour: Navy(dark blue)


    CPU: AMD FX 4100 Quad Core
    RAM: 8GB
    GPU: Nvidia 260GTX
    Driver: 310
    OS: Ubuntu 12.10 64-bit

    Only tried TF2 so far…
    Lower FPS than Windows.. Average 180 on Windows.. 60 on Linux..
    Lots of Micro-stutters. (every 5-10 seconds there’s a ~200-500ms lockup).
    Lots of missing letters. Screenshot

    Favorite Color?.. Gray?

Viewing 15 posts - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.